Oracle 11i Navigation

Training Manual
Document Identification

<table>
<thead>
<tr>
<th>Revision</th>
<th>Version 1.0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compiled By:</td>
<td>Tracy Hudson</td>
</tr>
<tr>
<td>Signature:</td>
<td>Original signed</td>
</tr>
<tr>
<td>Issue Date:</td>
<td>25 October 2005</td>
</tr>
</tbody>
</table>

Authorities

<table>
<thead>
<tr>
<th>Name</th>
<th>Signature</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change Manager</td>
<td>Sue Hickton</td>
<td>25 October 2004</td>
</tr>
<tr>
<td></td>
<td>Original signed</td>
<td></td>
</tr>
</tbody>
</table>

Document History

<table>
<thead>
<tr>
<th>Date</th>
<th>Version</th>
<th>Author</th>
<th>Description of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>25-10-2005</td>
<td>1.0</td>
<td>Tracy Hudson</td>
<td>Compilation for Training</td>
</tr>
</tbody>
</table>
Oracle 11i - Navigation Course

Student Guide
Table of Contents

Oracle 11i Implementation Project ................................................................. 1-1
  Why are we re-implementing Oracle? ......................................................... 1-3
  New Functionality in 11i ............................................................................ 1-4
  Course Structure ....................................................................................... 1-5

Oracle 11i - Abbreviations ........................................................................ 2-1
  Oracle 11i - Abbreviations ....................................................................... 2-2

Oracle 11i - Navigation Course Objectives .............................................. 3-1
  Oracle 11i – Navigation Course Objectives .............................................. 3-2
  Course Objectives .................................................................................... 3-3

Oracle 11i - Logging On and Off .............................................................. 4-1
  Oracle 11i - Logging On and Off .............................................................. 4-2
  Objectives ............................................................................................... 4-3
  Logging On to Oracle Applications .......................................................... 4-4
  E-Business Suite Homepage to Oracle Applications .............................. 4-5
  Choosing a Responsibility ........................................................................ 4-6
  Navigator ................................................................................................. 4-7
  Navigator Region Tabs ............................................................................ 4-8
  Expanding or Collapsing the Navigation List .......................................... 4-9
  Expanding or Collapsing Several Items .................................................. 4-10
  Changing Your Password ....................................................................... 4-11
  Switch Responsibility ............................................................................. 4-12
  Logging Off of Oracle Applications ....................................................... 4-13
  Demonstration ....................................................................................... 4-14
    Practice - Logging On and Off .............................................................. 4-15
    SOLUTION – Logging On and Off ......................................................... 4-16
  Summary ............................................................................................... 4-18

Oracle 11i - Using Forms and Menus ....................................................... 5-1
  Oracle 11i - Using Forms and Menus ....................................................... 5-2
  Lesson Objectives ................................................................................... 5-3
  Navigator Window .................................................................................. 5-4
  Form Terminology .................................................................................. 5-5
  Terminology Review Questions ............................................................. 5-9
    Solution – Terminology Review ............................................................ 5-10
    Field Colors ....................................................................................... 5-11
    The Toolbar ....................................................................................... 5-12
    The Toolbar Icons ............................................................................. 5-13
    Toolbar Review Questions ................................................................ 5-17
      Solution – Terminology Review ......................................................... 5-18
  Menus and Special Areas ....................................................................... 5-19
  File Menu .............................................................................................. 5-20
  Edit Menu ............................................................................................. 5-21
  View Menu ............................................................................................ 5-23
  Tools Menus .......................................................................................... 5-25
  Window Menu ...................................................................................... 5-26
  Help Menu ............................................................................................ 5-27
  Commonly Used Commands ................................................................. 5-28
  Demonstration ....................................................................................... 5-29
    Practice - Using Forms and Menus ........................................................ 5-30
    SOLUTION – Using Forms and Menus ................................................ 5-31
  Summary ............................................................................................... 5-32

Oracle 11i - Shortcuts .............................................................................. 6-1
  Oracle 11i - Shortcuts ........................................................................... 6-2
  Lesson Objectives .................................................................................. 6-3
  Top Ten List ........................................................................................... 6-4
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oracle 11i - Accessing Online Help</td>
<td>7-1</td>
</tr>
<tr>
<td>Lesson Objectives</td>
<td>7-2</td>
</tr>
<tr>
<td>Using Window Help</td>
<td>7-3</td>
</tr>
<tr>
<td>Using Online Help</td>
<td>7-4</td>
</tr>
<tr>
<td>Searching for Help Information</td>
<td>7-5</td>
</tr>
<tr>
<td>Review Question</td>
<td>7-6</td>
</tr>
<tr>
<td>SOLUTION – Online Help</td>
<td>7-7</td>
</tr>
<tr>
<td>Search Syntax</td>
<td>7-8</td>
</tr>
<tr>
<td>Oracle Applications Library</td>
<td>7-9</td>
</tr>
<tr>
<td>Review Question</td>
<td>7-10</td>
</tr>
<tr>
<td>SOLUTION – Online Help</td>
<td>7-11</td>
</tr>
<tr>
<td>Error Messages</td>
<td>7-12</td>
</tr>
<tr>
<td>Record History</td>
<td>7-13</td>
</tr>
<tr>
<td>Demonstration</td>
<td>7-14</td>
</tr>
<tr>
<td>Practice - Accessing Online Help</td>
<td>7-15</td>
</tr>
<tr>
<td>SOLUTION – Accessing Online Help</td>
<td>7-16</td>
</tr>
<tr>
<td>Summary</td>
<td>7-17</td>
</tr>
<tr>
<td>Oracle 11i - Setting Personal Profile Options</td>
<td>8-1</td>
</tr>
<tr>
<td>Lesson Objectives</td>
<td>8-2</td>
</tr>
<tr>
<td>Profile Options</td>
<td>8-3</td>
</tr>
<tr>
<td>Security Profile Hierarchy</td>
<td>8-4</td>
</tr>
<tr>
<td>Setting Personal Profile Values</td>
<td>8-5</td>
</tr>
<tr>
<td>Profile Option Values</td>
<td>8-6</td>
</tr>
<tr>
<td>Personal Profiles</td>
<td>8-8</td>
</tr>
<tr>
<td>Demonstration</td>
<td>8-9</td>
</tr>
<tr>
<td>Summary</td>
<td>8-11</td>
</tr>
<tr>
<td>Oracle 11i - Where to from here</td>
<td>9-1</td>
</tr>
<tr>
<td>Where to from here</td>
<td>9-3</td>
</tr>
</tbody>
</table>
Oracle 11i Implementation Project

Chapter 1
Oracle 11i Implementation Project
Why are we re-implementing Oracle?

- Current Oracle system is not supported
- Chart of Accounts has been re-implemented
- Chance to implement new functionality
- Interfaces being re-written

Interfaces are the transfer of data from one system i.e. Callista to another system i.e. Oracle, which happens automatically. This allows the Oracle system to be used as the core financial system for the University.
New Functionality in 11i

- **Payables** – Redesigned Invoice entry screen, XML invoices and payments, email remittance advice
- **Cash Management** – new module for bank reconciliations
- **Fixed Assets** – iAssets, Asset maintenance, transfer Assets by category, Rollback/Recreate journal entries
- **Receivables** – Improved User Interface, Invoice preview and reprint, XML invoices, Credit Management
- **General Ledger** – XML Publisher, eJournals, Enhanced Drilldown & T Accounts, Automatic Journal Reversal, Web based account inquiries
You will be attending this Oracle 11i training session to enhance your understanding of the new finance system.

The above diagram shows the prerequisite training you will be attending, plus non-mandatory training sessions that we recommend.
Oracle 11i - Abbreviations

Chapter 2
Some common abbreviations used in this course:-

- (M) = Menu
- (B) = Button
- (Help) = Oracle Online Help Screens
- (N) = Navigator
- (I) = Icon
- (T) = Tab
- LOV = List of Values
- (H) = Hyperlink

Common Abbreviations
During this training session and future training sessions you will be enrolled in you will come across some standard menu path abbreviations that is used through the Oracle 11i documentation.
Oracle 11i - Navigation
Course Objectives

Chapter 3
After this course, you should be able to:

- Logon and off of Oracle Applications
- Reset your password
- Understand how to use forms and menus
- Customise the presentation of data using shortcuts
- Access online help
- Set personal user profile options
- Review attachments and exporting to Excel

Course Overview

This course discusses the basic features of accessing and navigating within Oracle Applications, Release 11i. You will learn to log on and off, use forms and menus, access online help, use shortcuts and set user profiles.

You will also be reviewing some new functionality such as attaching documentation to journals and invoices, exporting data to excel. These will be demonstrated to you during this class, but you will learn how to perform these functions when you attend the Oracle Inquiries training course.
Oracle 11i - Logging On and Off

Chapter 4
Oracle 11i - Logging On and Off
Objectives

After completing this lesson, you should be able to do the following:

- Log on to Oracle Applications
- Choose a Responsibility
- Use the Oracle Applications Navigator
- Change your password
- Switch responsibilities
- Log off of Oracle Applications

Objectives

To use Oracle Applications productively, you need to understand the various components of a form, the menu paths, and keystrokes necessary to access and navigate within the system to perform your various job tasks.

A Responsibility is a level of authority within Oracle. It enables your access to those functions and areas that is appropriate for your role within the organisation. You can have one or more responsibilities.
Getting a logon and password to Oracle 11i Applications

To start Oracle 11i, you will need to navigate to the correct website. Currently this site is http://www.ecu.edu.au/msc/fsr/ (Financial Applications) and Oracle 11i access will be obtainable through here from 10 January 2006.

To access the Oracle 11i environment you will need a logon and password. The logon and password will be your ADS logon (which is the logon and password you use to log into your computer each day).

During training sessions in December 2005, January and February 2006, you will be asked to apply for access in the new Oracle 11i system. Access will not be automatically granted through your ADS logon in the new Oracle 11i system. If you are not sure of your logon and password to the new system after 10 January 2006, please contact the Systems Helpdesk on ext 2772 or at mscsystems@ecu.edu.au.

Your user name connects you to your responsibilities, which controls your access to applications, functions, reports and data (this will be related to your job function).
After you log on to Oracle Applications your E-Business Suite Homepage is displayed. From here you can:

- View and Respond to Notifications
- Set personal user preferences
- Navigate to other frequently used functions or web pages

When you logon onto Oracle for the first time you will receive an Initiator Security Warning when you choose a responsibility.

- Select “Grant this session always”, this notification will not appear again
Choosing a Responsibility

Each user has at least one responsibility and several users can share the same responsibility. Your Applications Administrator can assign you any of the standard responsibilities provided with Oracle Applications, or create custom responsibilities for you. Click on the underlined link in the Application section to select your responsibility and then click on the underlined link for a specific function to open that function.

As part of these training sessions we will be selecting:-
1. Select the ECU Generic Reporting and Inquiries Responsibility
2. Select Journals (GL) from the Inquiries sub-heading
Navigator Window

The Navigator window displays the name of the responsibility you select in the title bar. Use this window to navigate to a form so you can perform a specific business flow. You can navigate to the forms that are displayed in a navigation list on the left side of the Navigator window.

You can click on the tabs to access different regions.

As part of these training sessions we will be selecting:-
1. From the Menu Bar, Select File > Close Form
2. From the Tool Bar, click on the Navigator Icon
### Navigator Region Tabs

<table>
<thead>
<tr>
<th>Region Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Functions</td>
<td>Displays the windows that you can navigate to in a navigation list on the left side of the Navigate window</td>
</tr>
<tr>
<td>Documents</td>
<td>Displays links to documents that you have created</td>
</tr>
<tr>
<td>Processes</td>
<td>Displays a visual map of a business process</td>
</tr>
</tbody>
</table>

**Functions Tab**

The Functions tab displays all of the Applications functions that you can access for the responsibility that you have selected.

**Documents Tab**

If you have a document, such as a particular purchase order or invoice that you want to access later, you can create a link to the document using the Navigator's Document feature.

The Navigator’s Document feature allows you to create as many links as you want and save them in the Documents region of the Navigator window. When you use a link to open a document, Oracle Applications opens the document in the appropriate form window. You can access the Document region using the tab control.

**Processes Tab (will only appear from certain responsibilities)**

The Processes region of the Navigator (the “Process Navigator”) shows you the automated business flows across Oracle Applications forms.
Expanding or Collapsing the Navigation List

Choose one of the following methods to expand an item to its next sublevel window:

- Double-click the item.
- Select the item and click Open.
- Select the item and click Expand.

To collapse an expanded item, select the item and click Collapse.

Expanding or Collapsing the Navigation List

Each user can access the Oracle Applications forms in several ways so that they can use the system quickly, according to their own computer style. Use the various buttons on the Navigator to manipulate list items.
Expanding or Collapsing Several Items

To expand or collapse several items at once, click one of the following buttons:

- **Expand All Children** expands all the sublevels of the currently selected item.
- **Expand All** expands all the sublevels of all expandable items in the navigation list.
- **Collapse All** collapses all currently expanded items in the navigation list.

Expanding or Collapsing Several Items

Click any of these buttons to expand or collapse several items listed on the Navigator Menu. These functions are also available in the Tools menu.
Changing Your Password

You can change your password at any time during your session. It will be in effect the next time that you log on.

How to Change Your Password:

- **Professional Interface:**
  - (M) Edit > Preferences > Change Password
  - Enter your old and new passwords and click (B) OK.
- **Self-Service**
  - (M) User Preferences > Password Settings
  - Enter your old and new passwords and click the (B) Apply
Switch Responsibility

You can switch your responsibility at any time during your session. You can then access functions pertinent to that responsibility.

How to Switch Your Responsibility

• (M) File > Switch Responsibility
• Select a new responsibility from the list of values and click OK.

Alternatively, if you are at the Home Page (Navigator window) you can click the Top Hat on the Toolbar to switch responsibilities.
Logging Off of Oracle Applications

(M) File > Exit Oracle Applications > OK
Use this method so that your username is cleared from system access.

Logging Off of Oracle Applications

It is important to exit the system in this manner to ensure that your user name is cleared from system access.

You can also close the Multiple Document Interface (MDI) window or use the function key F4. When you have logged out of the Core Application above, you will be returned to the Oracle E-Business Suite home page and you can then click on the Logout menu item at the top right hand side of the screen.
Demonstration

M A N A G E M E N T  S E R V I C E S  C E N T R E

- Logging on
- Changing your password
- Switching responsibilities
Practice - Logging On and Off

Overview

In this practice you will log on to Oracle Applications, examine several components of the Navigator window and log off.

Tasks

1. Log on to Oracle Applications using the user name and password supplied by the Instructor.
3. Choose **Account (GL)** from the **Inquiries** functions menu.
4. Take about five minutes to familiarise yourself with the functionality discussed earlier in this lesson.
5. Exit Oracle Applications properly when you are finished so you will not permit unauthorised access to another user.
SOLUTION – Logging On and Off

Log On to Oracle Applications

1. Login to Oracle Applications: enter "TRAINXX" in the User Name field and “ORACLE” in the password field and then click the Login button.

2. You should see the Oracle E-Business Suite Home page displayed.

3. Select the ECU GL Journals User responsibility
   - Use the Tab key to go down the list, select ECU GL Journals User, and then press Enter
   - Use your mouse to select ECU GL Journals User

4. Select Account (GL) function under the Inquiries sub-heading

5. Return to the Navigator
   (B) Navigator
   (M) File > Close Form

6. Switch Responsibilities
   • (M) File > Switch Responsibilities and select ECU Generic Reporting and Inquiries

7. Expand the first Menu, + Report Requests to view the sub-menus
   • Highlight '+ Report Requests ' and click the (B) +
   • Highlight '+ Report Requests ' and double-click
   • Highlight '+ Report Requests ' and click the (B) Open on the bottom of the Navigator window

8. Expand all the menu options shown in this Navigator window
   • Click the (B) ++ (double plus signs) on the left side of the Navigator window.

9. Collapse all functions shown on this Navigator window
   • Click the (B) -- (double minus signs) on the left side of the Navigator window.

10. Log off Oracle Applications.
    • (M) File > Exit Oracle Applications
    • Click (B) OK
    • Close the Oracle Applications Internet Explorer screen

2. You should see the Oracle E-Business Suite Home page displayed.
- Click Logout at the top right hand corner of the screen
In this lesson, you should have learned how to:

- Log on to Oracle Applications
- Choose a Responsibility
- Use the Oracle Applications Navigator
- Change your password
- Switch responsibilities
- Log off of Oracle Applications
Oracle 11i - Using Forms and Menus

Chapter 5
Lesson Objectives

After this lesson, you should be able to:

- Open a form from the Navigator window
- Define basic form terminology and characteristics
- Use the Applications toolbar
- Discuss keyboard shortcuts
- Use various menu options
- Understand how to view attachments and export data to Excel

Lesson Overview

This lesson discusses using forms and menus from the Navigator window. Form terminology, the Applications toolbar, and keyboard shortcuts will be explained to enable you to move quickly within Oracle Applications forms. You will also learn how to change your security access and password.

You will be shown how to view attachments and export data to Excel, but you will be examining this functionality in full during the Oracle 11i Inquiries training course.
Navigator Window

Use the Navigator window to navigate to a form that lets you perform a specific business activity. The Navigator window is always present during your session of Oracle Applications and displays the name of your current responsibility in its window title.
Form Terminology

Oracle Applications works specifically in a Web-enabled environment. It is important to understand the terminology of the components within an Oracle Applications form. Common terms used in Oracle Applications forms are listed below.

**Menu Bar** - Use pull-down menus from this menu bar to navigate or perform actions within a form.

**Window** - An area where the user interacts with an application (Many windows can be open at one time and you can access these “overlapping” windows to perform data entry or data search activities.)

**Window Title** - Text in the title bar that indicates the name of the window, and usually, context information pertinent to the information in that window.

**MDI window** - A master container window that houses all windows, toolbars, and application windows.

**Tool tips** - Iconic bubble help that you can use to determine the function of a button on the toolbar.
Form Terminology

Form Terminology (continued)

**Region** - A logical grouping of fields set apart from other fields by a box outline

**Region tab** - A collection of regions that occupy the same space in a window where only one region can be displayed at a time

**Field** - An area in a window that displays data or enables you to enter data

**Button** - A graphic element that initiates a predefined action when you click it
Form Terminology (continued)

**Option button** - A button that indicates an individual selection is available within an option group

**Modal window** - A window that requires you to act on its content before continuing

**Scrolling region** - A region, containing a scroll bar, in which to view other fields
Form Terminology (continued)

**Record or Row** - A set of one or more related data items from a table or view that are grouped for processing

**Check box** - A box in which you can toggle between an on/off or yes/no state for a particular value

**LOV icon** - An icon that you can click to display a list of values (LOV) for the current field

**Poplist** - A poplist lets you choose a single value from a short list
Review Questions

Label the numbered boxes in the slide.
Solution – Terminology Review

1. LOV
2. Check Box
3. Block
4. Record or Row
5. Poplist
6. Tabbed Region
Field Colors

<table>
<thead>
<tr>
<th>Field Colour</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>White</td>
<td>Allow data entry</td>
</tr>
<tr>
<td>White with green text</td>
<td>Indicate drill-down capability</td>
</tr>
<tr>
<td>Yellow</td>
<td>Require data entry</td>
</tr>
<tr>
<td>Grey with black text</td>
<td>Are display only</td>
</tr>
<tr>
<td>Blue</td>
<td>Indicate fields to use in Query-Enter mode</td>
</tr>
</tbody>
</table>

Field Colors

Each block contains fields you use to enter, view, update, or delete information. A field prompt describes each field by telling you what kind of information appears in the field or what kind of information you should enter in the field. Fields are color coded to indicate their type as follows:

- **White Fields** - allow data entry
- **White Fields with Green Text** - indicate drill-down capability
- **Yellow Fields** - require data entry
- **Grey Fields with Black Text** - are display-only
- **Blue Fields** - indicate fields to use in Query-Enter mode

The term field generally refers to a text field, an area in a window that either displays data or allows you to enter data. However, a field can also include a button, check box, option group, or poplist.
The Toolbar

The Toolbar is a collection of iconic buttons, where each button performs a specific action when you choose it. Each toolbar button replicates a commonly-used menu bar item. Depending on the context of the current field or window, a toolbar button can be enabled or disabled, this is represented by the tool tip being greyed out or coloured. You can display help or a tool tip for an enabled toolbar button by holding your mouse over the button.
The Toolbar Icons

- New
- Find
- Show Navigator

**Toolbar Icons**

- **New** - Creates a new record in the active form.
- **Find** - Displays the Find window to retrieve records.
- **Show Navigator** - Displays the Navigator window.
The Toolbar Icons

- **Save** - Saves any pending changes in the active form.
- **Next Step** - Updates the Process workflow in the Navigator by advancing to the next step in the process. It also saves any pending changes in the active form.
- **Switch Responsibility** – Allows the user to select another Responsibility if the user has more than one Responsibility.
- **Print** - Prints the current screen that the cursor is in. In some cases it may print a report associated with the current data.
- **Close Form** - Closes all windows of the current form.
The Toolbar Icons

- Cut
- Copy
- Paste
- Clear Record
- Delete

**Toolbar Icons**

- **Cut** - Cut the current selection to the clipboard.
- **Copy** - Copies current selection to the clipboard.
- **Paste** - Pastes from the clipboard into the current field.
- **Clear Record** - Erases the current record from the window.
- **Delete** - Deletes the current record from the database.
The Toolbar Icons

- **Edit Field** - Displays the Editor window for the current field.
- **Zoom** - Invokes custom-defined Zoom (drilldown behavior).
- **Translations** - Invokes the Translations window (if multiple languages are installed).
- **Attachments** - Invokes the Attachments window. If one or more attachments already exist, the icon changes to a paper clip on a piece of paper.
- **Folder Tools** - Displays the folder tool palette.
- **Window Help** - Displays help for the current window.

Copyright © Edith Cowan University, 2005. All rights reserved.

Oracle 11i - Using Forms and Menus
Revision V1.0  Chapter 5 - Page 16
Toolbar Review

Label the toolbar icons.
Solution – Toolbar Review

1. Find
2. Navigator
3. Save
4. Print
5. Close Form
6. Clear Record
7. Delete
8. Attachment
9. Window Help
Menus and Special Areas

Oracle Applications use an MDI. All windows are displayed inside a single container window, with a single toolbar, menu, message line, and status line attached to that window.

- The **message line** displays pertinent information for processing your form.
- The **status line** displays status information.
- The **pulldown menu** bar includes the following menus:
  - File
  - Edit
  - View
  - Folder
  - Tools
  - Window
  - Help.

Use these menus to navigate through a form, to edit or retrieve data, or to perform various other actions.

In addition to the pulldown menu, you can access the following menu items by right mouse clicking on an item: Cut, Copy, Paste, Folder Menu, and Help.
Using the File Menu

**New** - Creates a new record in the active form.

**Open** - Opens the detail screen for the current selection.

**Save** - Saves any pending changes in the active form.

**Save and Proceed** - Saves pending changes in the active form and advances to the next record.

**Next Step** - Updates the Process workflow in the Navigator by advancing to the next step in the process.

**Export** - Exports information in your current form to a browser.

**Place on Navigator** - Creates an icon in the Documents tab of the Navigator which can be used to recall the active form and its current record.

**Switch Responsibility** - Allows you to change the responsibility for your current log on.

**Print** - Prints your current window. An application may override this action to instead allow printing of one or more specific reports.

**Close Form** - Closes all windows of the current form.

**Exit Oracle Applications** - Quits Oracle Applications.
Edit Menu

Using the Edit Menu

**Undo Typing** - Undoes any typing done in a field before the field is exited and returns the field to the most recent value.

**Cut** - Cut the current selection to the clipboard.

**Copy** - Copy the current selection to the clipboard.

**Paste** - Paste the contents of the clipboard into the current field.

**Duplicate Record Above** - Copies all values from the prior record to the current record.

**Duplicate Field Above** - Copies the value of the current field from the prior row.

**Clear Record** - Erases the current record from the window.

**Clear Field** - Clears the data from the current field.

**Clear Block** - Erases all records from the current block.

**Clear Form** - Erases any pending changes from the current form.

**Delete** - Deletes the current record from the database.

**Select All** - Selects all records (for blocks with multi-select).

**Deselect All** - Deselects all selected records except for the current record (for blocks with multi-select).

**Edit Field** - Displays the Editor window for the current field.

**Preferences Change Password** - Displays the Change Password dialog box.
Preferences Profiles - Displays the Profiles window.
Using the View Menu

**Show Navigator** - Displays the Navigator window.

**Zoom** - Invokes custom defined zooms.

**Find** - Displays the Find window to retrieve records.

**Find All** - Retrieves all records.

**Query by Example Enter** - Invokes 'Enter Query' mode to enter search criteria for a query-by-example.

**Query by Example Run** - Executes the query-by-example.

**Query by Example Cancel** - Cancels the query-by-example by exiting from 'Enter Query' mode.

**Query by Example Show Last Criteria** - Recovers the search criteria used in the previous query-by-example.

**Query by Example Count Matching Records** - Counts the number of records that would be retrieved if you ran the current query-by-example.

**Record First** - Moves the cursor to the first record.

**Record Last** - Moves the cursor to the last record.

**Translations** - Displays the Translations window.

**Attachments** - Displays the Attachments window.

**Summary/Detail** - Switch between the summary and detail views of a combination block.
Requests - Displays the Request window.
Using the Tools Menu

The Tools menus may contain up to fifteen product-specific entries. Examples of product-specific entries may include a list of commonly used Inquiry windows in the application, or a commonly used window that a user may want to display for a quick reference.

In some applications, up to two additional menus may appear after the Tools menu. These menus are usually labeled “Reports” and “Actions”, but may be different depending on the products that are being used. Like the Tools menu, these menus each allow up to 15 product-specific entries.
Using the Window Menu

- **Cascade** - Displays any open windows in a "cascaded" or stair-stepped fashion.
- **Tile Horizontally** - Displays any open windows in a horizontally "tiled" (non-overlapping) fashion.
- **Tile Vertically** - Displays any open windows in a vertically "tiled" (non-overlapping) fashion.
- **1 (Title of Open Window)** - Displays a list of open windows titles in the order in which they are stacked.
Using the Help Menu

**Window Help** - Displays Help for the current window

**Oracle Applications Library** - Displays a window that lists all available Oracle Applications Help text

**Keyboard Help** - Displays the current mapping of specific functions and menu options

**Diagnostics** - There are multiple Diagnostics menus used for coding and debugging.

**Record History** - Displays information about who created and updated the current record.

**About Oracle Applications** - Displays information about the current window and application
Commonly Used Commands

- File > Save
- File > Exit Oracle Applications
- File > Switch Responsibility
- File > Close Form
- Edit > Preferences > Change Password
- View > Find
- View > Query By Example
- Help > Window Help
- Edit > Clear Record
Demonstration

- Open a form from the Navigator window
- Use the Applications toolbar
- Use various menu options
- View attachments
- Export data to Excel
Practice - Using Forms and Menus

Overview

In this practice you will log on to Oracle Applications, view the various menu bar options, and log off.

Tasks

1. Log on to Oracle Applications using the user name and password supplied by the Instructor.
2. Choose the ECU Generic Reporting and Inquiries responsibility link on the E-Business Suite Home Page.
3. Choose Journal (GL) from the Inquiries functions menu.
4. Take about five minutes to familiarise yourself with the menu and tool bars as discussed earlier in this lesson.
5. Exit Oracle Applications properly when you are finished so you will not permit unauthorised access to another user.
SOLUTION – Using Forms and Menus

1. Login to Oracle Applications: enter "TRAINXX" in the User Name field and “ORACLE” in the password field and then click the Login button.

2. You should see the Oracle E-Business Suite Home page displayed.

3. Select the ECU Generic Reporting and Inquiries Responsibility.
   − Use the Tab key to go down the list and select your Responsibility, then press Enter
   − Use your mouse to click on the Responsibility

4. Select Journal (GL) function under the Inquiries functions menu

5. Return to the Navigator
   (B) Navigator
   Or select File > Close Form

6. Take a tour of the drop-down menus available for this form:
   • Click each menu on the menu bar, starting with File, to see which options are available for each.
   • Close the Users window

7. Log off Oracle Applications.
   • (M) File > Exit Oracle Applications
   • Click (B) OK
   • Close the Oracle Applications Internet Explorer screen

8. You should see the Oracle E-Business Suite Home page displayed.
   • Click Logout at the top right hand cover of the screen
In this lesson, you should have learned about:

- Opening a form from the Navigator window
- Defining basic form terminology and characteristics
- Using the Applications toolbar
- Discussing keyboard shortcuts
- Using various menu options
- Understanding how to view attachments and export data to Excel
Oracle 11i - Shortcuts
Lesson Objectives

After this lesson you should be able to:

- Create a personal Navigator top ten list
- Use Shortcut keys
- Understand the concepts of saving a document to your Navigator for easy access

Lesson Overview

You can use several features of Oracle Applications to enhance your proficiency in the system. This lesson explains how to use these features to make your access to the system easier.

You will be shown how to save a document to your Navigator, but you will be examining this functionality in full during the Oracle 11i Inquiries training course.
Top Ten List

If there are forms that you use frequently, you can add them to a navigation top ten list located on the right side of the Navigator window. The top ten list displays your forms numerically so you can choose them instantly without having to search for them in the navigation list. You can create a different top ten list for each responsibility for which you have access. A top ten list is unique for the responsibility and user sign-on combination that you use.

How to Create a Navigation Top Ten List:-
1. Select a form from the navigation list by highlighting it in the Navigator window.
2. Click the right pointing arrow to add that form to the top ten list.
3. Click the left facing arrow to remove a form from your top ten list.
4. To open a form in your top ten list, type the number that precedes the form you want to open. You can also click on it and press Open, or double-click on it.

Note: Sometimes the form that you add changes names when it appears in the top ten listing. An example is that Suppliers becomes Vendors. Also note that the tenth entry is numbered 0 (zero), so it can be invoked by pressing a single keystroke also.
Keyboard Shortcuts

Using Keyboard Help

Experienced Oracle Applications users can bypass the menu by using a keyboard shortcut, a specific combination of keystrokes that performs the same function as a corresponding menu item. Oracle Applications assigns many commonly used functions, such as Run Query, Save, or Clear Record to keyboard shortcuts.

You can display a list of the keyboard shortcuts that map to your computer terminal's keyboard at any time.

To display a list of keyboard shortcuts:-
(M) Help > Keyboard Help...
Or Ctrl+K
When you finish scrolling through the listing, click OK to close the window.
Placing Documents on the Navigator

Some Oracle Applications enable you to save a document to the Navigator for easy access when you first log into the system.

The File menu will illuminate the Place on Navigator option when it is available within your application. One example is the Requests window of the SRS form.

The Documents tab on the Navigator window will display icons or list those documents that you have saved. This shortcut eliminates having to query the database to find your specific document. Instead, you can select it from the Navigator window and go directly to the window containing your document.

Note: You will learn how to complete this exercise in the Oracle 11i Inquiries Training Course.

How to Access a Document from the Navigator Window:-

1. Select the Documents tab displayed at the Navigator window.
2. Select the document from the list of documents or document icons displayed to go directly to the applications form window for that document.

You can change the label of the document to whatever you like by pressing the Rename button.

You can delete the document from your Navigator by pressing Delete. Note that this will not delete the actual document, only your shortcut to it.
• Create a personal Navigator top ten list
• Review shortcut keys
• Save a document to your Navigator
Practice - Shortcuts

Overview

In this practice you will log on to Oracle Applications, create a top ten list, review shortcut keys and log off.

Tasks

1. Log on to Oracle Applications using the user name and password supplied by the Instructor.

2. Choose the ECU Generic Reporting and Inquiries responsibility link on the E-Business Suite Home Page.

3. Choose Account (GL) from the Inquiries functions menu.

4. Take about five minutes to familiarise yourself with the functionality discussed earlier in this lesson.

5. Exit Oracle Applications properly when you are finished so you will not permit unauthorised access to another user.
Log On to Oracle Applications

1. Login to Oracle Applications: enter "TRAINXX" in the User Name field and “ORACLE” in the password field and then click the Login button.

2. You should see the Oracle E-Business Suite Home page displayed.

3. Select the ECU Generic Reporting and Inquiries responsibility
   - Use the Tab key to go down the list, select ECU Generic Reporting and Inquiries, and then press Enter
   - Use your mouse to select ECU Generic Reporting and Inquiries

4. Select Account (GL) function under the Inquiries sub-heading

5. Return to the Navigator
   (B) Navigator
   (M) File > Close Form

6. Move several menu options to your top ten list
   - Enter GL Journal
   - Run Standard Reports

7. Review the keyboard shortcuts
   • (M) Help > Keyboard Help

8. Log off Oracle Applications.
   • (M) File > Exit Oracle Applications
   • Click (B) OK
   • Close the Oracle Applications Internet Explorer screen

9. You should see the Oracle E-Business Suite Home page displayed.
   • Click Logout at the top right hand cover of the screen
Summary

In this lesson you should have learned the following:

- Creating a top ten list
- Saving a document to the Navigator
- Shortcut keys
Oracle 11i - Accessing Online Help
Lesson Objectives

After this lesson, you should be able to:

- Display Help information online
- View explanations for application messages and errors
- Identify who created and updated a row of data

Lesson Overview

The online documentation and help features can greatly enhance your ability to understand how to accomplish tasks using Oracle Applications. You can also determine how to identify the user responsible for the entry or maintenance of a record for further clarification of a business issue. This lesson explains how to obtain online information about the application and records.
Accessing Window Help

Oracle Applications provides you with a complete online help facility through your web browser tool.

How to Display Help for a Current Window:-

1. Select Help > Window Help. A help window is displayed, providing information and a list of topics associated with the current application window.
2. Click on a topic of interest to display more detailed information.
Using Online Help

A Web browser window appears when you use the help system. This window contains search and navigation frames on the left part of the window, and a frame that displays the help information on the right side of the window.

- Navigation frame displays the top-level topics for your responsibility, arranged in a tree control.
- Document frame can provide information on the application window containing the cursor, information on the topic selected in the navigation frame, or a list of topics that are a result of using the frame.
- If the document frame contains a list of topics associated with the window, you can click on a topic to display more detailed information.
Searching for Help Information

You can perform a search to find the Oracle Applications help information you want. Simply enter your query in the text field located in the top-left frame of the browser window when viewing help, then click the adjacent Find button.

A list of titles, ranked by relevance and linked to the documents in question, is returned from your search in the right-hand document frame. Click on whichever title seems to best answer your needs to display the complete document in this frame. If the document does not fully answer your questions, use your browser's Back button to return to the list of titles and try another.
To access online help you can do any of the following:
1. (M) Help > Window Help
2. Click the ? toolbar icon
3. Press [Ctrl] + [H]
4. All of the above
5. None of the above
Solution – Online Help

To access online help you can do any of the following:

1. (M) Help > Window Help
2. Click the ? toolbar icon
3. Press [Ctrl] + [H]
4. All of the above
5. None of the above

4. All of the above
Search Syntax

The search syntax to use in constructing your query can be any of those shown in the table in the slide.

**Example:**
You want to know how to create a budget organisation in Oracle General Ledger. You enter “budget organization” in the search field, and click Find. A linked list of help documents that contain this phrase appears in the document frame. You click on one that seems appropriate and start reading.

**Note:** Oracle is written in American English, and as such you must be specific in your spelling of words i.e. ‘customize’, ‘check’.
You can display help for any of the Oracle Applications products.

Oracle Applications Library

You can access online help for any Oracle Applications product and you can reference that product’s documentation online as well. All of the applications are listed in the navigation frame on the left hand side of the window.
Review Question

You can access Oracle Applications User’s Guides online using the online help system.
True or False?
You can access Oracle Applications User's Guides online using the online help system. True or False?

Look in the navigation frame for the name of the guide.
Error Messages

• To give you a hint, the application displays a short message in the message line.
• To inform you of an error, the application displays an error window.
• A History button also appears in the error window if an error of more serious nature occurs.

Error Message Codes

Generally, messages and errors are preceded by a message or error code.
• Codes that are prefixed by FRM arise from Oracle Forms, the underlying product that provides Oracle Applications with its graphical user interface.
• Codes that contain the prefix ORA arise from the Oracle database.
• Codes that are prefixed by APP arise from Oracle Applications.
These codes help your Applications Administrator or Oracle support representative diagnose the errors that you may encounter.
Record History

You can always display information about a record that has been previously saved.

- Who created the record
- Date of creation
- Database table or view where the record resides
- Who last changed the record using Oracle Applications
- Date of the last change
- User’s logon

How to Learn About the Current Record:-

1. (M) Help > Record History. A window appears that shows you information about the current record.
2. Click OK to close the window.
Demonstration

- Display Online Help information
- Identify who created a record
Practice - Accessing Online Help

Overview

In this practice you will log on to Oracle Applications, use various aspect of Oracle Applications online help and log off.

Tasks

1. Log on to Oracle Applications using the user name and password supplied by the Instructor.

2. Choose the ECU Generic Reporting and Inquiries responsibility link on the E-Business Suite Home Page.

3. Select the Journal (GL) function under the sub-heading of Inquiries which will take you to the professional applications interface.

3. Take about five minutes to familiarise yourself with the Oracle Applications online help functionality as discussed earlier in this lesson.
   - Browse the Documentation Library
   - Record creation information

4. Exit Oracle Applications properly when you are finished so you will not permit unauthorised access to another user.
1. Login to Oracle Applications: enter "TRAINXX" in the User Name field and "ORACLE" in the password field and then click the Login button.

2. You should see the Oracle E-Business Suite Home page displayed.

3. Select the ECU Generic Reporting and Inquiries Responsibility.
   - Use the Tab key to go down the list and select your Responsibility, then press Enter
   - Use your mouse to click on the Responsibility

4. Select Journal (GL) function under the Inquiries functions menu

5. Click Find, to locate all journals that have been entered.

6. Click the Review Journal button on any of the journals that appear on the screen.

7. Find out which user created this record:-
   - (M) Help > Record History

8. Browse the Documentation Library:-
   - (M) Help > Window Help
   - The Enter Journal Window Help Screen will appear

   - (M) File > Exit Oracle Applications
   - Click (B) OK
   - Close the Oracle Applications Internet Explorer screen

10. You should see the Oracle E-Business Suite Home page displayed.
    - Click Logout at the top right hand cover of the screen.
In this lesson you should have learned to:

- Accessing online Help
- Using window Help
- Searching for Help information
- Finding Help for all Oracle Applications
- Viewing error messages
- Viewing Record History
Oracle 11i - Setting Personal Profile Options

Chapter 8
Oracle 11i - Setting Personal Profile Options
Lesson Objectives

After this lesson, you should be able to:

- View user profile options that are common to all Oracle Applications
- Change your profile options to customise your default preferences

Lesson Overview

Using profile options, you can control the behavior of certain Oracle Applications features. This lesson explains the levels of profile options and how you can change them to suit your personal business requirements.
Overview of User Profiles

A user profile is a collection of changeable options that affect the way your applications run. Oracle Applications establishes a value for each option in a user’s profile when the user logs on or changes responsibility. You can change the value of most user profile options at any time. Oracle Applications provides this and other options so that you can alter the behavior of your applications to suit your own preferences.

Oracle Applications uses a set of profiles options that are common to all application products. In addition, each application has its own unique set of profile options.

There are three Profile Hierarchy Types

- Security
- Organisation
- Server

and each type has different levels that values can be set. One or more options can be set at one or more of levels. The Application Administrator is responsible for maintaining most Profile options.
Security Profile Hierarchy

Oracle Applications treats profile levels as a hierarchy, where User is the highest level of the hierarchy, followed by Responsibility, Application, and at the lowest level, Site. Higher-level option values override lower-level option values.

User Level
User level option values affect the way applications run for a given application user.

Responsibility Level
Responsibility level option values affect the way applications run for all users of a given responsibility.

Application Level
Application level option values affect the way a given application runs.

Site Level
Site level option values affect the way all applications run at a given installation site. Typically, your Applications Administrator will set this option after installing Oracle Applications at a site.
Setting Personal Profile Values

You can change a user profile option value using the Personal Profile Values window or you can display all your options to review the values your Applications Administrator has set for them.

If you do not set your own user level option values, your user profile options assume the values your Applications Administrator has set for them at the various levels.

Note: The above screen shot may vary from your screen as the profile options displayed will be determined by your Responsibility.

How to Change a Profile Option Value:-
1. (M) Edit > Preferences > Profiles, or
2. (N) > User Profile

This window displays all your user profile options and their values.

If you wish to display only specific user profile options you can Query the specific Profile in the Name field.

The name of the profile option appears in the Profile Name field while the Default Value field displays the run-time value of that option. The System Administrator sets default values for many of the profile options. Some profile options may not display a default value.
2. Move your cursor to the User Value field of the option whose value you wish to modify.
3. Enter a new value or select a value from the LOV for the option if it is updateable (white field).
Profile Option Values

If the profile option is not updateable (grey field), the message “Item is protected against update,” appears on the message line when you try to change the value. You can change most of your user profile options; values you enter in the User Value field override values preset by the Applications Administrator.

A few profile options cannot be changed, but are displayed for informational purposes only. For most personal profile options, Oracle Applications automatically checks the value you enter to ensure it is valid.

**Attention**: Number or date values are not validated, therefore, you must make sure that you enter a valid value for profile options that require a number or date; otherwise, your personal profile option may not work as you expect.

Though you cannot delete a profile option from your personal profile, you can clear its value (if it is updateable) by highlighting the field and pressing [Backspace] or by choosing Clear, Field from the Edit menu. If you clear the value, the change does not take effect until you sign on again or change responsibilities.

- (M) File > Save to save your change, or
- Ctrl-S, or
- Disc icon from Toolbar

Your change will take effect when you either change responsibilities or login again.
All reports and programs in Oracle Applications run as concurrent processes whether you submit them using the Submit Requests window or a product-specific submission window. Submitted reports and programs are referred to as concurrent requests. Each concurrent request runs according to a set of concurrent processing options.

The Personal Profiles Values window sets the defaults for these profiles. If you want to change the value of a default, you must change the value of the corresponding user profile option using the Personal Profiles Values window in your application.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concurrent: Save Output</td>
<td>Specifies whether to save report output to a file</td>
</tr>
<tr>
<td>Printer</td>
<td>Specifies the printer for printing your report output</td>
</tr>
<tr>
<td>Concurrent: Show Requests Summary After Each Request Submission</td>
<td>Display Requests Summary each time a request is submitted or not</td>
</tr>
<tr>
<td>Viewer: Default Font Size</td>
<td>Set default font size for report output in the Report Viewer window</td>
</tr>
</tbody>
</table>
View user profile options and update
Summary

In this lesson you should have learned to:

- View your personal User Profile
Enrol in your next training course:-
  - Oracle 11i Inquiries
  - eApprovers

Systems Support from the 10th January 2006
  - Call: 2772
  - Email: mscsystems@ecu.edu.au